Referencing update
Minor incident
Referencing
2023-02-23 13:08 UTC
· 1 hour, 13 minutes
Updates
Resolved
February 23, 2023 · 14:21 UTC
We’ve identified and resolved the technical issue, which was causing delays on some status updates and completed referencing reports showing on the platform. Moving forward thews will be updated in the platform, and normal service will resume.
Issue
February 23, 2023 · 13:10 UTC
We’re experiencing technical issues with our referencing software, which is causing delays on any new status updates and completed referencing reports showing on the platform.
This means that you cannot currently see the most recent status of your references or any newly completed referencing reports
← Back