Microsoft Azure outage impact - Service disruption

Major incident Web application Referencing
2025-10-09 08:07 UTC · 8 hours, 50 minutes

Updates

Resolved

Microsoft has confirmed that their systems are now fully operational, and we’re no longer seeing any related impact. This incident is now resolved.

October 9, 2025 · 16:56 UTC
Update

Microsoft reports that customers in our region should now be experiencing consistent availability, with slightly elevated latencies continuing to decrease as more resources are recovered.

The Goodlord platform is currently stable, though some users may still experience slower login times while recovery work continues.

We’ll keep monitoring the situation and share another update if there are any changes.

October 9, 2025 · 15:22 UTC
Investigating

Microsoft is still reporting issues in our region (UK South), and we’re continuing to see some instability for users of the Goodlord platform. We expect stability to improve as Microsoft progresses with their recovery efforts.

October 9, 2025 · 13:05 UTC
Update

Microsoft has confirmed that capacity is unavailable across Europe, the Middle East, and Africa due to a failure in some underlying infrastructure components. They are in the process of restarting affected systems, and services are gradually recovering.

We are monitoring Azure’s recovery closely and will provide updates as the situation progresses. Based on Microsoft’s latest information, full restoration is expected within the next 90 minutes.

Thank you for your patience while Azure works to fully resolve this issue.

October 9, 2025 · 11:34 UTC
Investigating

Our team is actively monitoring the situation and working to restore full service as quickly as possible. Microsoft has identified the underlying issue within Azure and is working on a resolution. We’ll continue to provide updates as more information becomes available.

October 9, 2025 · 10:47 UTC
Issue

We’re currently experiencing a service disruption due to a global Microsoft Azure outage. This is affecting parts of the Goodlord and Referencing platforms, and you may notice issues when trying to use certain features.

Our team is actively monitoring the situation and working to restore full service as soon as possible. We’ll continue to post updates here as we know more.

October 9, 2025 · 08:58 UTC

← Back