Slow Performance

Major incident Web application
2022-04-27 12:41 UTC · 46 minutes

Updates

Resolved

This incident has now been resolved.

April 27, 2022 · 13:27 UTC
Monitoring

We have released a fix and will continue to monitor the situation. Thank you for your patience.

April 27, 2022 · 12:46 UTC
Issue

We are aware of slow performance of the Goodlord application. We’re working to get the app back up and running for everyone as soon as possible.

April 27, 2022 · 12:42 UTC

← Back